Instalación de Spotify en Debian Wheezy. Error de dependencias con libssl0.9.8.

No Gravatar

Tras el lanzamiento de Debian Wheezy, como siempre, existe un periodo de adaptación de los diferentes paquetes hasta que se actualizan para la versión estable de turno. En este caso, me ha tocado lidiar con una instalación limpia de Debian Wheezy y el cliente de Spotify. Este programa utiliza la versión 0.9.8 de la librería de cifrado ssl, cuando en Wheezy se ha pasado a usar la versión 1.0, con el consiguiente recochineo que eso conlleva para algunas tareas. En concreto, el mensaje de error que nos lanza la herramienta apt-get al intentar instalar el cliente de Spotify (spotify-client) es el siguiente:

apt-get install spotify-client
[...]
Los siguientes paquetes tienen dependencias incumplidas:

spotify-client : Depende: libssl0.9.8 pero no es instalable
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

El método de solucionarlo por suerte es bastante sencillo. Simplemente debemos bajarnos desde la siguiente URL (seleccionando la arquitectura necesaria), el archivo .deb de libssl 0.9.8 e instalarlo.

http://packages.debian.org/squeeze/libssl0.9.8

La instalación del paquete es, como siempre, bastante sencilla (como root):

 dpkg -i ruta/del/paquete/nombre_del_paquete.deb

Si lo hemos descargado en el Escritorio para una arquitectura i396, por ejemplo:

 dpkg -i ~/Escritorio/libssl0.9.8_0.9.8o-4squeeze14_i386.deb

Inmediatamente después, la instalación de Spotify que lancemos no dará ningún error:

 apt-get install spotify-client
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Se instalarán los siguientes paquetes extras:
libqt4-dbus libqt4-xml libqtcore4 libqtdbus4 libqtgui4 qdbus
Paquetes sugeridos:
qt4-qtconfig
Se instalarán los siguientes paquetes NUEVOS:
libqt4-dbus libqt4-xml libqtcore4 libqtdbus4 libqtgui4 qdbus spotify-client
0 actualizados, 7 se instalarán, 0 para eliminar y 0 no actualizados.
Se necesita descargar 33,1 MB/40,0 MB de archivos.
Se utilizarán 101 MB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]?
Des:1 http://repository.spotify.com/ stable/non-free spotify-client i386 1:0.9.0.133.gd18ed58.259-1 [33,1 MB]
Descargados 33,1 MB en 45seg. (732 kB/s)
Seleccionando el paquete libqtcore4:i386 previamente no seleccionado.
(Leyendo la base de datos ... 155518 ficheros o directorios instalados actualmente.)
Desempaquetando libqtcore4:i386 (de .../libqtcore4_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete libqt4-xml:i386 previamente no seleccionado.
Desempaquetando libqt4-xml:i386 (de .../libqt4-xml_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete libqtdbus4:i386 previamente no seleccionado.
Desempaquetando libqtdbus4:i386 (de .../libqtdbus4_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete libqtgui4:i386 previamente no seleccionado.
Desempaquetando libqtgui4:i386 (de .../libqtgui4_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete qdbus previamente no seleccionado.
Desempaquetando qdbus (de .../qdbus_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete libqt4-dbus:i386 previamente no seleccionado.
Desempaquetando libqt4-dbus:i386 (de .../libqt4-dbus_4%3a4.8.2+dfsg-11_i386.deb) ...
Seleccionando el paquete spotify-client previamente no seleccionado.
Desempaquetando spotify-client (de .../spotify-client_1%3a0.9.0.133.gd18ed58.259-1_i386.deb) ...
Procesando disparadores para man-db ...
Configurando libqtcore4:i386 (4:4.8.2+dfsg-11) ...
Configurando libqt4-xml:i386 (4:4.8.2+dfsg-11) ...
Configurando libqtdbus4:i386 (4:4.8.2+dfsg-11) ...
Configurando libqtgui4:i386 (4:4.8.2+dfsg-11) ...
Configurando qdbus (4:4.8.2+dfsg-11) ...
Configurando libqt4-dbus:i386 (4:4.8.2+dfsg-11) ...
Configurando spotify-client (1:0.9.0.133.gd18ed58.259-1) ...
Procesando disparadores para menu ...

Y con eso… le voilà! A disfrutar del cliente nativo en Debian Wheezy

2 comentarios en «Instalación de Spotify en Debian Wheezy. Error de dependencias con libssl0.9.8.»

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.